本文へジャンプ

特設サイト一覧

PC Online's Weekly

PR

2009年6月22日 page:1/3次へ

USBメモリー/SDカードのデータを自動バックアップするツール(第124回)

クジラ飛行机=スーパークリエーター

印刷ページ
(執筆時の情報に基づいており、現在では異なる場合があります)

 最近はUSBメモリーやデジカメのSDカードなど、フラッシュメモリー製品を機会が増えています。今回は、これら記録メディア内のデータを自動的にバックアップするツールを作ってみます。メディアをパソコンに挿入したタイミングでバックアップ処理を実行する部分に注目してください。

プログラム~記録メディアを挿入と同時にバックアップ

 下記のプログラムを実行しておくと、USBメモリーなどを挿入すると同時にマイドキュメント内に「外部メモリ取込」というフォルダーを作り、そこへファイルをコピーします。コピーが終わると、「ハードウェアの安全な取り外し」ツールを起動します。

プログラムを起動させておくと、メディア挿入と同時にバックアップを行います
拡大表示


#-----------------------------------------------------------------------
# 記録メディアを挿入と同時にバックアップ
#-----------------------------------------------------------------------
保存先トップ=「{マイドキュメント}外部メモリ取込\\」
#-----------------------------------------------------------------------
母艦のタイトルは「記録メディアを挿入してください。」
母艦のデバイス挿入した時は
  ドライブ=空
  使用可能ドライブ取得して反復
    対象のドライブ種類をTに代入。
    もし、T=「取り外し可能」ならば
      ドライブに対象を配列追加
  もし、要素数(ドライブ)>1ならば
    「どのドライブをバックアップしますか?」をドライブでボタン選択。
    ドライブ=それ。
  もし、ドライブが空ならば、戻る。
  #---------------------------------------------------------------------
  # 重複無くバックアップする処理
  ドライブの全ファイル列挙
  反復
    F=対象からファイル名抽出。
    対象のファイル更新日時をDに代入。
    EXT=対象から拡張子抽出
    識別キー1=Dを「yyyy-mm-dd」に日時形式変換
    識別キー2=Dを「hhnnss」に日時形式変換
    保存フォルダ=「{保存先トップ}{識別キー1}\\」
    保存先=「{保存フォルダ}{F}.{識別キー2}{EXT}」
    もし、保存先が存在するならば、続ける。# 重複は避ける
    母艦のタイトルは「コピー中:{F}」
    保存フォルダにフォルダ作成。
    対象から保存先にファイルコピー。
  ここまで。
  「コピーが完了しました。取り外しツールを起動します」と言う。
  ハードウェア取り外し起動。#
  母艦のタイトルは「記録メディアを挿入してください。」
#-----------------------------------------------------------------------

【改造のヒント】

 プログラムの上から4行目にある変数「保存先トップ」を書き換えると、保存先のフォルダーを変更できます。

 さらに、プログラムの27行目では、ファイルの重複を防ぐために、ファイルの更新日時をコピー先のファイル名に付け加えています。もしも、ファイル名を変えたくない場合は、ここを下記のように修正できます。(ただし、同じ日に同じ名前のファイルを作らないことを前提としています。デジカメのメモリカードなら問題が少ないでしょう。)


保存先=「{保存フォルダ}{F}」


ショッピング

 
 

最新ランキング

PICK UP

FacebookTwitter

ITpro記事ランキング

ITpro Active記事ランキング

PC Online会員登録

最新刊のご案内

  • 日経ベストPC+デジタル2014冬号

    日経ベストPC+デジタル
    2014冬号

    【最新PC購入術】新Office、新CPUが登場!
    ●最新タブレット購入ガイド ●新世代スマホ購入術
    ●Wi-Fi&モバイル通信 最強活用術
    ●周辺機器オールカタログ ★特別付録付き

  • PC自作の鉄則!2015

    PC自作の鉄則!2015

    ★パーツ選びからトラブル解決まで★
    自作で必要な要素を6つのパートに分け、
    基本から応用、最新トレンドまで幅広く解説。
    全ての自作ユーザーの必携書!

  • 日経PC21【保存版】バックナンバーDVD2011-2013

    日経PC21
    【保存版】バックナンバーDVD
    2011-2013

    ★好評発売中!★
    2011年1月号~2014年4月号の
    過去3年+4カ月分の本誌40冊分の記事と、
    この期間の冊子付録およびディスク付録、
    全14点分のコンテンツを1枚のDVDに収録!

  • 2014年最新版アンドロイドは初期設定で使うな

    2014年最新版
    アンドロイドは初期設定で使うな

    スマートフォンを買ったものの、「使いにくさ」や
    「動作の遅さ」、「バッテリーの持ちの悪さ」などに
    悩んでいる人のための「アンドロイド端末」活用の
    決定版です。

最新の誌面から

  • 日経パソコン 2014年12月22日号

    日経パソコン 2014年12月22日号

    パソコンを仕事と生活に活かす総合情報誌
    ・ネットの怪現象に対処する
    ・パソコン不要のデジタルグッズ
    ・画像ファイルの保管と活用の最新ワザ ほか

  • 日経PC21 2015年1月号

    日経PC21 2015年1月号

    ビジネスマンのパソコン誌
    ・ベールを脱いだWindows10
    ・思い出をデジタルで永久保存
    ・パソコン×スマホでクラウド手帳術 ほか

日経パソコンスキルアップ倶楽部